Daniels Blog
29Apr/109

Meine Ubuntu 10.04 Lucid Lynx Problemchen (und wie ich sie gelöst habe)

Der Luchs ist da! Deshalb ist es wie schon bei Karmic an der Zeit alle Änderungen zu dokumentieren, die ich vornehmen musste, damit alles nach meinen Vorstellungen läuft. Diese Liste wird über die Lebenszeit des Luchses sicherlich noch etwas wachsen. Einige Probleme sind sehr speziell, andere könnten auch andere Benutzer interessieren. Im Großen und Ganzen bin ich schwer begeistert von 10.04: Alles wirkt etwas smoother, schneller und aufgeräumter. Karmic hat mir zwar gute Dienste geleistet, aber den Luchs habe ich bereits jetzt ins Herz geschlossen. Euch allen ein schönes halbes Jahr (oder sogar 3?) mit Ubuntu 10.04 Lucid Lynx!

Problemchen #1: Fensterbuttons nach rechts verschieben

Zum Glück nur einmal Copy/Paste....


gconftool-2 --set /apps/metacity/general/button_layout --type string "menu:minimize,maximize,close"

Problemchen #2: Miese Flash Performance

Seit Karmic wurden die Standardeinstellungen für den Radeon-Treiber geändert. Meine Mobility Radeon 9600 auf einem Asus M6N kommt im Zusammenspiel mit Flash damit nicht klar. Webseiten mit Flash pushen die CPU auf 100%. Mit dieser xorg.conf klappt es:

Section "Device"
	Identifier	"Configured Video Device"
	Option          "AccelMethod" "XAA"
EndSection

Problemchen #3: Fensterskalierung bei Pokerstars

In Pokerstars unter Wine skalieren die Tische nicht mit, wenn man das Tischfenster resized. Mit einem speziellen Eintrag in der user.ini im Pokerstarsverzeichnis lässt sich das beheben. Nach einem Neustart von Pokerstars lässt sich das Fenster mit F5 auf die richtige Größe bringen.

# user.ini
[Options]
f5redrawtable=1


Problemchen #4: Links in Pokerstars

In Pokerstars unter Wine öffnen angeklickte Links den Browser nicht.


"wine regedit" starten
Key HKEY_CLASSES_ROOT\http\shell\open\command suchen
In diesem Key "%1" nach "-nohome" anhängen


Problemchen #5: ffmpeg mit unfreien Codecs installieren

ffmpeg ist super zum konvertieren von Videos. Um auch unfreie Codecs nutzen zu können (z.B. h264, AAC) muss man ffmpeg selbst kompilieren. Das original Howto ist hier.


Problemchen #6: Logitech Quickcam Chat funktioniert unter Skype nicht

Die Kamera benötigt eine spezielle Library. So klappt es:

# Skype starten
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

Danke an Arun


Problemchen #7: Es werden nicht alle Auflösungen und Wiederholraten meines externen Monitors erkannt

Eine Anpassung der xorg.conf mit den richtigen Werten funktioniert:

# /etc/X11/xorg.conf
Section "Monitor"
        Identifier      "NOVITAS"
        Option          "VGA"
        HorizSync       30-80
        VertRefresh     50-75
        ModeLine        "1024x768@75" 94.43 1024 1056 1528 1560 768 782 792 807
EndSection


Section "Screen"
        Identifier      "Default Screen"
        Device          "Configured Video Device"
        Monitor         "NOVITAS"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1027x768@75" "1024x768" "800x600"
        EndSubSection
EndSection


Problemchen #8: Der "Dokumentbetrachter" kann nicht drucken.

Geht doch. Hatte nur Probleme mit einem ganz bestimmten Dokument. Alle anderen funktionieren.


Problemchen #9: Der Ziffernblock meiner Tastatur geht nicht mehr

Wow was ist das denn? Jetzt wirds langsam nervig 🙂
"Mauszeiger per Tastatur steuern" war aktiv. Ist das eine neue Standardeinstellung?
(unter System > Einstellungen > Tastatur > Maustasten). Nach dem Deaktivieren dieses Features ging es wieder.


Problemchen #10: Lautstärkeregler im Panel ohne E-Mail Icon (Benachrichtigungsanzeige)

Seit Lucid sind der Lautstärkeregler und die Steuerung für Evolution und Messenger gebündelt als "Benachrichtigungsanzeige". Ich benutze Evolution nicht und das E-mail-Icon nimmt Platz weg.

Unter System -> Einstellungen -> Startprogramme "gnome-volume-control-applet" eintragen um nur die Lautstärkensteuerung ohne das Brief-Icon zu bekommen.


Problemchen #11: Aktuellste Adobe-Flash Version installieren


#!/bin/bash
# 
# http://labs.adobe.com/downloads/flashplayer10.html 
#

sudo su
cd /tmp
wget http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_1_rc2_linux_041910.tar.gz
tar xvf /tmp/flashplayer10_1_rc2_linux_041910.tar.gz
mv /usr/lib/flashplugin-installer/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so.orig
mv /tmp/libflashplayer.so /usr/lib/flashplugin-installer/
rm /tmp/flashplayer10_1_rc2_linux_041910.tar.gz

hat dir dieser Artikel gefallen?

Dann abonniere doch diesen Blog per RSS Feed!

Kommentare (9) Trackbacks (0)
  1. Nachtrag zum letzten Post:

    Ich habe x Versuche gemacht, das root passwort über den recovery mode bzw grub zu resetten. Leider ohne Erfolg

  2. So, ich habe nochmal versucht die Zeilenumbrüche zu richten. Normalerweise sollte das Skript so laufen. Eine Rückmeldung von jemandem, der es nochmal versucht hat wäre nett.

  3. Vielen Dank für die ffmpeg-Anleitung! Hab das jedoch nicht als Script, sondern jede Zeile einzeln ausgeführt (wg. evtl. Fehlersuche) hat aber alles einwandfrei geklappt. Nun funktioniert mein ffmpeg endlich auch auf 10.04 (vorher 9.04, da ging es einfacher…)

    Vielen Dank!

  4. Hallo ihr. Habt ihr mal versucht das Script von der Originalseite auszuführen? Der Link ist unter dem Tip. Ich habe es auf einer frischen Lucid-Installation gemacht und es hat sofort funktioniert. Es kann gut sein, dass ich hier im Blog immer noch nicht die Zeilenumbrüche richtig hinbekommen habe.

  5. ok, die datei hab ich jetzt. funzt aber trotzdem ned leider….

  6. wo find ich denn die v4l1compat.so? wenn ich versuche die lib32v4l zu installieren bekomme ich: amd – wrong irgendwas…

  7. Hallo Daniel

    Ich bin Ubuntu-Neuling (Ubuntu 10.04 32 bit) und wollte die ffmpeg-Kompilierung nach Deiner Methode durchführen.
    Am Ende des Installationsprozesses kommt folgende Meldung:

    ===================== Installations-Ergebnisse ==========================
    Makefile:1: config.mak: No such file or directory
    libavutil/Makefile:1: libavutil/../config.mak: No such file or directory
    libavutil/../subdir.mak:96: Warnung: Die Befehle für das Ziel »libavutil/« werden überschrieben
    libavutil/../subdir.mak:26: Warnung: Alte Befehle für das Ziel »libavutil/« werden ignoriert
    libavutil/../subdir.mak:96: Warnung: Die Befehle für das Ziel »libavutil/« werden überschrieben
    libavutil/../subdir.mak:96: Warnung: Alte Befehle für das Ziel »libavutil/« werden ignoriert
    Makefile:343: /tests/fate.mak: No such file or directory
    make: *** Keine Regel, um »/tests/fate.mak« zu erstellen. Schluss.

    **** Installation fehlgeschlagen. Breche Paket-Erzeugung ab.

    Räume auf…OK

    Auf Wiedersehen!

    bernd@bernd-desktop:~/ffmpeg/x264/ffmpeg$ hash x264 ffmpegsudo apt-get remove ffmpeg x264 libx264-dev
    bash: hash: x264: Nicht gefunden.
    bash: hash: ffmpegsudo: Nicht gefunden.
    bash: hash: remove: Nicht gefunden.
    bash: hash: ffmpeg: Nicht gefunden.
    bash: hash: x264: Nicht gefunden.
    bash: hash: libx264-dev: Nicht gefunden.
    bernd@bernd-desktop:~/ffmpeg/x264/ffmpeg$

    Was läuft hier falsch? Vielen Dank für eine kurze Anwort und viele Grüße

    Bernd

  8. @hannes Hey, danke. Habe leider immer wieder Probleme Code vernünftig in WordPress zu bekommen, wenn die Zeilen zu lang sind.

  9. hey meister den ./configure-befehl von ffmpeg haste aber nicht schön kopiert – da fehlt ja die mehr als die hälfte! Und nach dem make-befehl kommt noch der <> Ansonsten schöne arbeit so far


Leave a comment

Noch keine Trackbacks.